Topic: Building from Source for ARM-Linux


I tried building cyassl embedded SSL from source for arm-linux by typing: ./confgure --prefix /home/dev/SSL_ARM --host arm-linux
but I got the following output:

checking build system type... i686-pc-linux-gnu
checking host system type... Invalid configuration `arm-linux-gcc': system `gcc' not recognized
configure: error: /bin/bash build-aux/config.sub arm-linux-gcc failed
dev@ubuntu:~/cyassl-2.8.0$ sudo ./configure --prefix /home/dev/SSL_ARM/ --host arm-linux
checking build system type... i686-pc-linux-gnu
checking host system type... arm-unknown-linux-gnu
checking target system type... arm-unknown-linux-gnu
checking for arm-linux-gcc... no
checking for gcc... gcc
checking for arm-linux-g++... no
checking for arm-linux-c++... no
checking for arm-linux-gpp... no
checking for arm-linux-aCC... no
checking for arm-linux-CC... no
checking for arm-linux-cxx... no
checking for arm-linux-cc++... no
checking for arm-linux-cl.exe... no
checking for arm-linux-FCC... no
checking for arm-linux-KCC... no
checking for arm-linux-RCC... no
checking for arm-linux-xlC_r... no
checking for arm-linux-xlC... no
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes

Building sources with arm-linux gcc works fine. In this output you can see, that arm-linux-gcc is known by the system I'm working on.

dev@ubuntu:~$ arm-linux-gcc
arm-linux-gcc: no input files

I've currently installed eldk for building stuff with arm, which works fine for c and c++ source files and I also can compile libmodbus with it.

Any suggestions?

Thanks in advance



Re: Building from Source for ARM-Linux

Hi Robboe,

Can you try updating the config.guess and config.sub files found under:


with the ones attached here?


Post's attachments

config.guess 44.73 kb, 4 downloads since 2013-12-19 

config.sub 34.76 kb, 5 downloads since 2013-12-19 

You don't have the permssions to download the attachments of this post.

Re: Building from Source for ARM-Linux

Thanks this worked fine for me wink