1 (edited by Zeddi 2014-02-19 01:28:00)

Topic: [SOLVED] Undefined references to OCSP functions if NO_FILESYSTEM set

I saw that the embedded SSL client and server examples fail to link against the following methods if the NO_FILESYSTEM define is set:

  • CyaSSL_CTX_SetOCSP_OverrideURL

  • CyaSSL_CTX_EnableOCSP

I use the code from github as of Feb 2, 2014 (up to commit 51b3b1cb6cf35dedccd0311289d43aa8c628648d).

I think the problem is located within the file /src/ssl.c:
On line 2232, there is


and as far as I can tell, this #define is closed no earlier than on line 3309:

#endif /* NO_FILESYSTEM */

Inside this block are many methods using file operations, but also quite some which should imho be available independently of the filesystem, like the OCSP ones.


Re: [SOLVED] Undefined references to OCSP functions if NO_FILESYSTEM set

Thank you for the suggestion. I agree that should be changed. The newer OCSP configuration functions parallel the CRL configuration functions. I didn't think to move them outside the NO_FILESYSTEM fence. I have this on my list of things to change.