Topic: How to make a random static

I have implemented gen_seed_for_test and custom_rand_gen_seed and custom_rand_generate_block which just uses a static number.

but when I create an rng with wc_init_rng_ex , I get -209 "DRBG_CONT_FIPS_E"

I assume this is due to the health check under the hood, but considering a person is testing, how can they turn the checks off?

Share

Re: How to make a random static

Hi RyVel,

My first guess is a FIPS boundary check hash issue. If HAVE_FIPS (--enable-fips=v2) is set you must update the fips boundary hash in fips_test.c. See https://www.wolfssl.com/docs/fips-ready-user-guide/

Using a test seed won't cause this error, however a failure with the DRBG such as SHA256 returning FIPS_NOT_ALLOWED_E would.

Please review the FIPS ready user guide and let us know if that doesn't resolve it.

Thanks,
David Garske, wolfSSL

Share