Topic: SPI communication with Asus E15028 (Nuvoton NPCT750) via RPi 3

Hi,
I'm trying to talk to Asus E15028 with Nuvoton NPCT750 via Raspberry Pi, butalways get no data back (only zeros). Have somebody experience with this board? I found pinout here
WolfSSL is compiled with

--enable-wolftpm --enable-opensslextra --enable-libwebsockets --enable-certgen --enable-certreq --enable-certext --enable-pkcs7 --enable-cryptocb --enable-aescfb


and wolfTPM with

--enable-debug=io --with-wolfcrypt=../wolfSSL/inst --enable-nuvoton


I also see that wolfTPM can open /dev/spidev0.0 and sets 43MHz. I tried to connect WP and HOLD to Vcc and to GND (from more detailed pinout that I found in docs for compatible motherboard, is in attachment).
Output I always have:

pi@raspberrypi:~/build/wolfTPM/examples/native $ ./native_test 
TPM2 Demo using Native API's
TPM2_IoCb: Ret 257, Sz 5
    80 d4 00 00 00                                  | .....
    00 00 00 00 00                                  | .....
TPM2_Init failed 0x101: TPM_RC_FAILURE: Commands not being accepted because of a TPM failure

Share

Re: SPI communication with Asus E15028 (Nuvoton NPCT750) via RPi 3

Hi r-type,

That is a great little module ASUS has for their motherboard. The steps you listed for wolfTPM with direct /dev/spi access looks great. Make sure you have the right SPI chip select. The PI has two and they are "/dev/spidev0.0" and "/dev/spidev0.1". The modules Nuvoton provides for the Pi use CS0 (Pin 24).

Also the reset line is active low, so if pulled low it will hold in reset, so make sure it is high. Also you should make sure you have a pull-up on the Chip Select pin to make sure it is only active when the Pi drives it. I would leave the IRQ line alone and not tie to anything. Use 3.3v for VCC.

Thanks,
David Garske, wolfSSL

Share

Re: SPI communication with Asus E15028 (Nuvoton NPCT750) via RPi 3

Hi David,
thank you for your response. I connected RST with VCC to put it high. Or should I put pull-up resistor instead? I also put 10k resistor between VCC and CS0. But still no answer from device. I attached image with connections. May be I have to try with another Raspi ...

Post's attachments

Screenshot at 2021-09-21 09-44-31.png
Screenshot at 2021-09-21 09-44-31.png 571.59 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

Share