Topic: Curl with Wolf connect problems

Trying wolf with curl:
Building all with Visual Studio 2010, v100 toolset.

Using certs from:
renamed to:

In the app using curl, the curl log reports:

 Connected to ( port 443 (#0)
 successfully set certificate verify locations:
 CAfile: D:\Programming(D)\Workspaces\VS_2010 Workspaces\CurlLibTest\Curl_Local\bin\cacert.pem
 CApath: none
 subject alt name(s) or common name do not match ""
 Closing connection 0

Going back to the wolfssl project to see if it works, and trying the client.exe app with:

 client.exe -h -p 443 -a cacert.pem
  wolfSSL_connect error -188, ASN no signer error to confirm failure
  wolfSSL error: wolfSSL_connect failed

Im using the default user_settings.h file from the IDE/WIN folder, and:
I do not see FIPS defined anywhere.
Current new options added:

 #define WOLFSSL_DES_ECB        // for wolfSSL_DES_ecb_encrypt() used by curl
 #define WOLFSSL_ALT_CERT_CHAINS    // test fix client app connect - no fix

And have tried most all options from user_settings_all.h with no luck.

I'm assuming if I can get client.exe to work with certs, I can get curl to work.
Note calling:

 client.exe -h -p 443 -d  
 client.exe -h -p 443 -d -g 

works fine.

Also, the curl app with openssl works fine. I'm trying to get away from openssl.

Any suggestions?



Re: Curl with Wolf connect problems

Hello Gary,

Do you see this issue with curl for all sites, or just
Can you try the WOLFSSL_ALLOW_NO_CN_IN_SAN flag?
If that doesn't help, please generate a debug log by rebuilding with WOLFSSL_DEBUG defined and attach it here.  Please also include your curl command line or code.

For wolfSSL's client, try using -A to pass in your CA cert, not -a.



Re: Curl with Wolf connect problems

Thanks for the help Kareem.

Got everything to work.

For the wolfssl client.exe, the problem was not using the -A param
as you mentioned, and having the wolfSSL home dir messed up as
mentioned here:

For curl when building using the IDE Project file, it was not having
all the needed wolf #define options set up properly for both wolf
and curl.