1 (edited by protocold 2012-01-27 19:55:08)

Topic: wolfSSL 2.0.2 compile problem with curl

when compiling libcurl againt wolfssl 2.0.2 it does not compile with SSL.
When I check config.log, I found the following:

configure:22249: checking for InitCyaSSL in -lcyassl
/tmp/ccmPuvee.o(.text+0x18): In function `main': conftest.c: undefined reference to `InitCyaSSL' collect2: ld returned 1 exit status configure:22271: $? = 1

I have already followed the instruction to do ./configure --without-ssl --with-cyassl

Please advise.


Re: wolfSSL 2.0.2 compile problem with curl

I just downloaded the curl source and tried it myself with the same result.

To fix it I had to modify the file configure.ac and change line 1955 from:

     AC_CHECK_LIB(cyassl, InitCyaSSL,


     AC_CHECK_LIB(cyassl, CyaSSL_Init,

After that, you need to run autoconf, and then rerun your

./configure --with-cyassl --without-ssl

The output of the configure script should tell you which SSL it is going to use, or if it didn't find any SSL.