Topic: How to build yaSSL shared library?

[Message migrated from SourceForge forums]

(2008-10-01 06:36:17 UTC)

How to build yassl and taocrypt shared libraries?  I can seem to build only the static libs.  On Ubuntu 7.04 feisty; autoconf 2.5.0; automake 1.9.6; libtool 1.5.22.

(2008-10-01 21:42:37 UTC)

I've added support to configure for shared libs.  Though sourceforge is having problems with developer access to CVS after their migration yesterday so I can't check in the changes yet.  I'll post back after it's checked in.

Shared lib support in configure is checked in for yaSSL.  See: for details.

(2008-10-02 10:03:43 UTC)

That worked.  Thank you!  openssl-links target is perhaps an affected party.  You might want to check that.  I however was trying to build curl against yassl for a mips-linux-uclibc based embedded system.  Looks like yassl is a little too big for this particular box.  (libyassl 508K, libyacrypt 528K, plus C++ runtime perhaps? 

This was built with "./configure

--disable-zlib --enable-plain-c", have I done it right?)

Got a few questions here:

1. Perhaps I should try cyassl?  This certainly depends on the state of cyassl's openssl compatibility layer..

2. Is cyassl's openssl compat layer "good enough" for curl at this point?  Reason for asking is, in curl users' mailing list, I was told that although curl buids against yassl, it doesn't pass all test cases.  Further, no one has tried buidling curl against cyassl, so it probably stands much less chance.  (I was also told that it should not be too hard to make curl work with yassl's native API, but I'm on a schedule here...)

3. I did try building curl against cyassl, but curl's configure complained about missing libcrypto symbols (CRYPTO_lock etc.)  How can I build libctaocrypt properly?

Sorry about pestering.  But I'm sort of lost with both openssl and gnutls.  I was really excited to find yassl project...

(2008-10-02 11:08:24 UTC)

Q&A in curl users's list, if anyone wants to take a look...

(2008-10-02 19:19:21 UTC)
You might want to try --disable-debug and stripping the shared objects as well.  Though not sure if that will be enough for you.

I'll try to get CyaSSL to build with curl, it should be pretty close.  I'll post back on the results.